Google Play reports delayed after 7/16
Incident Report for Appfigures
Resolved
Reports with free app data from Google Play are now available up to and including the 20th. If anything still looks off, check in directly and we'll take a look!
Posted Jul 23, 2018 - 10:14 EDT
Monitoring
We've noticed that Google Play is behind with releasing reports with free app data for the last few days. While data may be available in the developer dashboard after the 16th, the raw reports are delayed. As soon as those are released we'll import for available accounts.

Google reports with paid data are available up to and including the 7/19.
Posted Jul 20, 2018 - 13:15 EDT