Google Play report delay as of 8/1
Incident Report for Appfigures
Resolved
Google recently released a handful of raw reports, specifically for 8/1 through 8/4. We're still waiting on reports for the 5th and the 6th however, these are currently in line with Google's usual delay. Once additional reports become available we'll be able to import for all accounts.
Posted Aug 07, 2018 - 10:40 EDT
Monitoring
Once again, Google Play is behind with releasing raw reports, for free apps, for all of August. So far data is available up to and including 7/31. While data may be displayed in the developer dashboard, the raw reports are unavailable. We'll import reports as soon as those are released.
Posted Aug 06, 2018 - 11:20 EDT