Sales data for free Android apps is delayed
Incident Report for Appfigures
Resolved
Reports for free Android apps are now available up to and including 8/11. Any auto importing account should be up to date as of this morning.
Posted Aug 13, 2018 - 11:05 EDT
Monitoring
Google has not released reports for free Android apps since Monday, 8/6, causing reports to show incomplete data. We'll automatically import reports when Google releases them.

FYI - Revenue is unaffected.
Posted Aug 10, 2018 - 12:21 EDT
This incident affected: Google Play (Downloads).