Intermittent access issues for some members
Incident Report for Appfigures
Resolved
We've identified the issue, a bad web node, and have disabled it until it can be checked more throughly.

Access has been restored. We're really sorry about this issue!
Posted 12 months ago. Dec 27, 2016 - 09:16 EST
Investigating
We're currently investigating an intermittent issue that's preventing some members from accessing reports.
Posted 12 months ago. Dec 27, 2016 - 06:10 EST