Incomplete reports for Google Play on 8/3
Incident Report for Appfigures
Resolved
Good news! Google finally updated reports for free Android apps on 8/3. We're in the process of reimporting reports for available accounts.

If you'd like your email report sent again with updated numbers or you're still seeing partial data for the day reach out directly and we can help.
Posted Aug 30, 2018 - 18:07 EDT
Update
As of today we're still waiting on the updated reports to be released. Any new info and we'll share with you here - hopefully those become available soon!
Posted Aug 20, 2018 - 13:59 EDT
Update
We're still waiting on reports for the 3rd to be regenerated. Once those are available we'll re-import reports for the day.
Posted Aug 17, 2018 - 13:14 EDT
Monitoring
We've found that Google Play released partial reports for free Android apps on 8/3. Numbers in your Google developer dashboard may be up to date however, raw reports are incomplete. We'll automatically import regenerated reports once those become available.
Posted Aug 15, 2018 - 12:07 EDT