Extreme load is causing site/API access errors
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 14, 2017 - 17:46 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Feb 14, 2017 - 17:39 EST