Delayed reviews
Incident Report for Appfigures
Resolved
We're confidently resolving the earlier review issue as we're once again up to date and reviews continue to pull in smoothly.
Posted 2 months ago. Jul 12, 2018 - 19:03 EDT
Monitoring
Due to increased load reviews for some apps have been coming in slower than they normally do. We increased capacity and are seeing reviews starting to come in normally now.
Posted 2 months ago. Jul 12, 2018 - 07:09 EDT
This incident affected: Apple (Reviews).