Apple Syncs and are Archive will be Slow or Unresponsive
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 28, 2017 - 17:04 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Feb 28, 2017 - 15:49 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Feb 28, 2017 - 13:59 EST