Slow to load ranks
Incident Report for Appfigures
Resolved
Resolving this as ranks continue to run successfully.
Posted 13 days ago. Oct 09, 2019 - 18:29 EDT
Monitoring
Ranks should be stable and reporting as expected. We'll continue to monitor ranks for a time to ensure everything is back to normal.
Posted 13 days ago. Oct 09, 2019 - 14:14 EDT
Investigating
We're experiencing slowness with ranks across reports and the API that we're working to identify and resolve.
Posted 13 days ago. Oct 09, 2019 - 13:14 EDT