Amazon review delays
Incident Report for Appfigures
Resolved
Reviews are back to a normal sync schedule.
Posted Aug 03, 2020 - 17:04 EDT
Monitoring
Amazon reviews are back up to speed. We'll keep an eye on these for a bit longer before resolving completely.
Posted Aug 03, 2020 - 16:30 EDT
Investigating
We're investigating delays with Amazon reviews. As more information becomes available we'll share that here.
Posted Aug 01, 2020 - 11:04 EDT
This incident affected: Amazon (Reviews).