Google Play subscription delay after 5/23
Incident Report for Appfigures
Resolved
Google Play subscriptions with complete data will be available up to and including 5/31.

In recent behavior, Google has released partial data (active subscriptions) for 6/1.
Posted 22 days ago. Jun 03, 2019 - 13:17 EDT
Update
Google has now released subscription reports up to and including the 27th of May, auto-importing accounts should have up to data for the period.

Partial data is available for the 28th - once additional data for the day is released we'll import that as well.
Posted 27 days ago. May 30, 2019 - 09:25 EDT
Monitoring
Google Play's subscription reports are currently delayed after May 23rd. We'll be keeping an eye on Google's delay until those reports are generated.

Google's dashboard is currently reporting subscription data up until the 26th however, we'll wait for the raw reports to be released for importing.

Any account set to automatically import will pull in the reports as they become available.
Posted 27 days ago. May 29, 2019 - 10:39 EDT