Delays with hourly keyword ranks
Incident Report for Appfigures
Resolved
Confirming hourly keyword ranks have returned to full capacity so we're confidently resolving this incident.
Posted Sep 24, 2019 - 17:08 EDT
Monitoring
We've released a fix to bring keyword ranks back up to full speed. We'll be monitoring the ranks over the next few hours before we look to completely resolve.
Posted Sep 24, 2019 - 13:27 EDT
Identified
We've identified an issue causing sporadic delays with keyword ranks and we are working to roll out a fix. We'll let you know as soon as ranks are 100% once again.
Posted Sep 24, 2019 - 09:00 EDT