Errors loading reviews
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Mar 03, 2020 - 14:10 EST
Monitoring
Reviews are successfully loading once again across the site. If you're still having any trouble please reach out directly.
Posted Mar 03, 2020 - 13:50 EST
Investigating
We're experiencing issues loading reviews through the reviews report and are working to identify and resolve this as soon as possible.
Posted Mar 03, 2020 - 13:45 EST