Issues syncing with Amazon Appstore
Incident Report for Appfigures
Resolved
Earlier trouble from Amazon has subsided and accounts are syncing as expected.
Posted Mar 25, 2022 - 13:35 EDT
Investigating
We're currently investigating an issue that's preventing some members from syncing Amazon App Store accounts.
Posted Mar 21, 2022 - 17:27 EDT
This incident affected: Amazon (Downloads & Revenue).