Site is unavailable
Incident Report for Appfigures
Resolved
This has been resolved
Posted Jun 13, 2019 - 16:04 EDT
Identified
A bad deploy is currently causing the site to be unavailable to some members. We're working to resolve this issue.
Posted Jun 13, 2019 - 15:59 EDT
This incident affected: Analytics.