AdWords duplication
Incident Report for Appfigures
Resolved
We've resolved the issue and removed duplicate data for affected AdWords accounts.
Posted Jun 14, 2018 - 09:44 EDT
Identified
We've identified an issue causing duplicate AdWords data for some members. We're in the process of resolving it and removing the duplication for affected accounts.
Posted Jun 13, 2018 - 13:42 EDT