Syncing issues with Steam
Incident Report for Appfigures
Resolved
We've rolled out an update that resolved the earlier connectivity issues, and are now syncing once again.
Posted Oct 08, 2018 - 15:45 EDT
Investigating
Our integration team is investigating an issue causing Steam syncs to fail. We're working to make necessary updates and we will return syncs to normal as soon as possible.
Posted Oct 01, 2018 - 10:10 EDT
This incident affected: Steam (Sales).