Google Play Downloads Delayed After 8/19
Incident Report for Appfigures
Resolved
Good news - earlier today Google released reports, with free app data, up to and including August 26th. We're in the process of importing data for available accounts. If you're "downloads" are still delayed for the last few days reach out directly and we can take a closer look.
Posted 21 days ago. Aug 28, 2019 - 16:40 EDT
Monitoring
Reports covering Google's free app downloads have not been released after the 19th of August. We'll start importing raw reports as soon as they are generated on Google's end.

Google's dashboard may be reporting recent days of downloads however, we use the raw reports to import data so we're waiting on those to be released.
Posted 24 days ago. Aug 26, 2019 - 10:00 EDT
This incident affected: Google Play (Downloads).