Usage syncs are running successfully for everyone again. If you have any usage delays after the 12th, reach out to the support team for a closer look.
Posted Sep 16, 2025 - 13:16 EDT
Monitoring
We've resolved the root cause and initiated a sync for the recent days for anyone affected by the usage delay. We'll monitor this new sync to make sure all recent days are up to date.
Posted Sep 16, 2025 - 10:46 EDT
Identified
We’ve identified an issue affecting Apple usage syncs for a handful of accounts, causing data delays. We're working on getting syncs back up to speed and making sure data from the 13th and 14th is fully imported.