Volatility of Google Play Ratings
Incident Report for Appfigures
Resolved
Good news 🎉We've heard from Google that the issue causing the volatility has been resolved, and our data confirms the resolution.

We'll be working with Google to try and update historic data -- if possible.

For now, ratings counts should be stable as they were before the change Google rolled out in August.
Posted Nov 24, 2019 - 16:59 EST
Monitoring
Over the last few weeks Google Play ratings have become very unstable for many apps. We've monitored big dips of 50%+ negative ratings one day, followed by the same amount in extra positive ratings the next day.

This volatility is noticeable back to August of 2019 and in recent weeks it has become much more pronounced, resulting in larger negative numbers.

We're not sure why it's happening, and have reached out to Google, but believe it's related to Google's roll-out of a new ratings system.

We'll update this incident if/when we get an update from Google.
Posted Nov 15, 2019 - 18:05 EST