Windows Verification Issues
Incident Report for Appfigures
Resolved
Microsoft verification issues continue to be behind us. If you're still seeing any issues reach out to support for a closer look at your individual use case.
Posted Nov 02, 2023 - 14:08 EDT
Monitoring
Windows verifications continue to run smoothly after a couple of updates have been released. We'll continue to monitor for a bit longer to ensure all remains this way.
Posted Nov 01, 2023 - 10:59 EDT
Identified
We've released a small fix to alleviate some of the issues with Windows verification, anyone running into those earlier issues should start to see the verification trouble subside.

You may continue to see intermittent errors when syncing Windows accounts manually.
Posted Oct 26, 2023 - 15:28 EDT
Investigating
We're investigating issues with Microsoft verification over the last few days. You may have already noticed an uptick in verification issues, or may run into them while we investigate further.

We have noticed the Windows store has been fairly unstable over the last week or so which may be related however, we're still investigating the root cause of the verification troubles.
Posted Oct 26, 2023 - 10:23 EDT
This incident affected: Windows Store (Sales).