Google still hasn't released download reports beyond June 17, so there's no change to report just yet. We're hoping Google resolves the delay soon, and as soon as new reports become available, we'll automatically import them.
Posted Jun 26, 2026 - 10:28 EDT
Update
We're still waiting on Google to release updated downloads after the 17th. As soon as additional days are available, we'll import them automatically.
Posted Jun 24, 2026 - 13:18 EDT
Identified
Download data from Google Play is currently stuck at July 17, though revenue data is still arriving normally and is available through yesterday.
We're checking with Google to see what's causing the delay, but for now we're all waiting on Google to release more recent download data.