Delays with Google's reports for free apps
Incident Report for Appfigures
Resolved
Google has since released data with reports up to November 25th. If you're not seeing data up to the 25th reach out to support for some help checking on your syncs.

We'll continue to monitor from our end as we're at the usual Google delay, of two to three days, with report release times.
Posted Nov 28, 2022 - 08:23 EST
Update
Data, for free Google apps, continues to be delayed after November 17th. We'll continue to monitor for any new dates.
Posted Nov 23, 2022 - 08:11 EST
Monitoring
Google's reports, covering free apps, are delayed after November 17th as that's the latest date available in downloadable reports. On the other hand, Google's reports covering paid apps/products are as up to date as possible with data for the 21st.

While Google normally has a delay of two to three days for free apps, the current delay has stretched beyond the usual - we'll continue to monitor for new days. As soon as additional dates become available we'll automatically import for all.
Posted Nov 22, 2022 - 18:16 EST
This incident affected: Google Play (Downloads).