Delays reporting reviews

Incident Report for Appfigures

Resolved

Reviews have caught up with what's available in the stores themselves. Reach out to support directly if you're still noticing anything unusual.
Posted Jun 08, 2023 - 14:27 EDT

Update

Reviews are continuing to catch up - we'll resolved once those are all set!
Posted Jun 05, 2023 - 11:38 EDT

Monitoring

We've rolled out the fix and reviews are updating for those that were impacted. As always, we're monitoring from our end as we bring reviews back up to date.
Posted Jun 05, 2023 - 10:41 EDT

Identified

We've identified the root cause and are rolling out a fix shortly.
Posted Jun 05, 2023 - 09:41 EDT

Investigating

We're investigating a delay in reporting reviews for some apps, impacting both Apple and Google. Some members will see reviews reporting through June 1st only, on site and in alerts. As we learn more about the delay we'll share that with you here.
Posted Jun 05, 2023 - 08:25 EDT
This incident affected: Apple (Reviews) and Google Play (Reviews).