Inconsistencies with Google Play verification
Incident Report for Appfigures
Resolved
Over the last few days we've been working to push out some updates to the verification flow with Google. With our improvements live verification is once again stable for those previously impacted accounts.

If you're still having any trouble please reach out directly for a closer look.
Posted Dec 31, 2019 - 10:35 EST
Update
We're continuing to work on a resolution for Google Play verification impacting a handful of accounts. As soon as we have some news we'll look to share with you here.
Posted Dec 19, 2019 - 09:26 EST
Identified
We've identified an issue impacting the verification process across a handful of Google Play accounts. As a result you may run into trouble when attempting to re-link an existing account or when adding a new account. The integration team is working to push out an update to this flow as quickly as possible.
Posted Dec 17, 2019 - 10:53 EST