There's still no new subscription report data from Google beyond June 14. We're continuing to monitor the delay, and as soon as Google releases the missing reports, we'll automatically import them for everyone.
Posted Jun 26, 2026 - 10:33 EDT
Identified
Google's subscription reports are currently delayed, with no new data being released after June 14.
We're monitoring the delay and have reached out to Google for more information. As soon as Google releases additional reporting days, we will automatically import the new data.
We'll post another update when we learn more or see reporting resume.
Posted Jun 24, 2026 - 06:51 EDT
This incident affects: Google Play (Subscriptions).