Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 26, 2024 - 18:00 EDT
Scheduled
We'll be performing some maintenance to our ratings collection and reporting systems. We estimate that there will be a 30 minute period in this maintenance window in which ratings reports will be unavailable.
Posted Aug 26, 2024 - 12:02 EDT
This scheduled maintenance affected: Platform and Apple (Ratings).