Slow report loading
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Apr 05, 2022 - 23:18 EDT
Monitoring
We've found and resolved this issue so reports should be loading quickly for everyone.
Posted Apr 05, 2022 - 18:14 EDT
Investigating
We're investigating an issue that's slowing down report loading
Posted Apr 05, 2022 - 13:45 EDT
This incident affected: Analytics.