All Steam accounts, new or existing, will once again be able to successfully link or refresh their connection. If you're still running into any trouble with either, reach out to the support team for help.
Posted Aug 19, 2024 - 09:30 EDT
Update
We're close to releasing an update for linking and refreshing Steam accounts. Early next week we expect to have good news.
Posted Aug 16, 2024 - 17:34 EDT
Update
We continue to work on updates to our Steam integration for linking new accounts or refreshing existing accounts. Hopefully within the next few days we'll have a positive update to share on the state of the integration.
Posted Aug 15, 2024 - 14:07 EDT
Identified
We've identified changes from Steam which impacts linking new accounts as well as updating existing accounts. Steam accounts that are currently importing will continue to sync daily as expected.
These changes from Steam will require a bit of time to address and get updates pushed out as well - we're looking to have this sorted out within a week or two. As we learn more about timing we'll share those updates here.