Importing Apple's delayed report for 5/8
Incident Report for Appfigures
Resolved
Good news! Apple's reports for both the 8th and the 9th have been released and are available to import for all accounts.
Posted 2 months ago. May 10, 2019 - 17:03 EDT
Monitoring
Apple's daily report for 5/8 was delayed. These reports were released earlier today (5/10) - a day late. We're now working to import these reports for available accounts.

Reports for the 9th, have not yet been released so we're still waiting on those to become available.
Posted 2 months ago. May 10, 2019 - 09:50 EDT