Google imports are back up and running. We’ll continue monitoring syncs to make sure everything stays on track.
Posted Apr 01, 2026 - 15:03 EDT
Investigating
We’re currently investigating delays with automatic Google imports. Syncs are running slower than normal, but manual syncs are working as expected in the meantime. We’ll share updates as we learn more.
Posted Apr 01, 2026 - 12:15 EDT
This incident affects: Google Play (Downloads, Revenue).