Amazon syncs have completed and data is as up to date as possible, once again!
Posted Apr 24, 2023 - 19:03 EDT
Monitoring
The fix is live and we're kicking off a sync for all Amazon accounts to bring everyone up to date.
Posted Apr 24, 2023 - 17:30 EDT
Identified
We detected a change to Amazon's reports impacting syncs beginning last week (April 17th) through today (April 24th). We're rolling out an update to these changes and will have up to date data available very soon.
Posted Apr 24, 2023 - 16:22 EDT
This incident affected: Amazon (Downloads & Revenue).