Usage Delays for Some App Store Connect Accounts

Incident Report for Appfigures

Resolved

Good news! We were able to get this resolved on Thursday of last week, much earlier than expected.

We've been monitoring usage syncs throughout the weekend, and everything has continued to update normally. This incident has now been resolved.
Posted Jul 06, 2026 - 07:45 EDT

Identified

We've identified the root cause of the usage sync delays affecting a small number of App Store Connect accounts.

We're working on a fix now, though it will take a little time to roll out. We're aiming to have everything resolved next week and will reach out directly to the affected accounts once their usage data is syncing normally again.
Posted Jul 01, 2026 - 15:55 EDT
This incident affected: Apple (Usage).