Amazon delay after the 28th
Incident Report for Appfigures
Resolved
Amazon reports are now available up to and including April 1st. We'll import reports for all accounts automatically.
Posted Apr 02, 2020 - 12:42 EDT
Monitoring
We're monitoring a delay from Amazon where sales reports after March 28th have not been generated. Once those reports do become available we will automatically sync for all Amazon accounts.
Posted Apr 01, 2020 - 15:07 EDT
This incident affected: Amazon (Downloads & Revenue).