Google Subscription Delays as of 2/26
Incident Report for Appfigures
Resolved
Google has released subscriptions reports, with updated data, up to and including March 12th. All accounts should be as up to date as possible with subscriptions now that we've re-sycned for everyone. If numbers between Feb. 26th and March 12th still look off, reach out to support for another look!
Posted Mar 14, 2022 - 13:55 EDT
Update
All still remains true here with static Active Subscriptions and no data for Activations or Cancellations from Google's subscription reports. We'll continue to keep an eye out for any changes.
Posted Mar 10, 2022 - 17:04 EST
Identified
Google Play is incredibly behind with subscription data after February 25th, for the majority of members. Although subscription reports have been released for recent days, Active Subscriptions numbers are static up to March 6th and Activations and Cancellations columns report zeros after the 25th. This is the case both in Google's dashboard as well as the exported reports we use.

As always, we'll re-import for everyone as soon as numbers are updated in reports from Google.
Posted Mar 09, 2022 - 11:59 EST
This incident affected: Google Play (Subscriptions).