Errors loading app panels

Incident Report for Appfigures

Resolved

After monitoring on our end, we can confirm app panels are working as expected and will continue going forward.
Posted Nov 05, 2025 - 13:49 EST

Monitoring

App panels are back up and running again. We'll keep an eye on it for a bit longer to make sure everything continues to loads as expected.
Posted Nov 05, 2025 - 10:58 EST

Update

We continue to investigate the root cause and will share further updates as they become available.
Posted Nov 05, 2025 - 10:11 EST

Investigating

Loading app panels through Competitor Comparison and Inspector reports is currently returning errors. We're investigating the root cause and working to get them back up as quickly as possible.
Posted Nov 05, 2025 - 09:48 EST