Ranks report errors and latecy
Incident Report for Appfigures
Resolved
Ranks imports continue to remain stable.
Posted Jun 13, 2024 - 14:57 EDT
Monitoring
This issue is now clearing up. We'll continue to monitor it going forward.
Posted Jun 13, 2024 - 06:23 EDT
Investigating
We're investigating an issue that's causing elevated error rates and latency in the ranks report.
Posted Jun 13, 2024 - 05:38 EDT
This incident affected: Amazon (Ranks), Windows Store (Ranks), Analytics, Apple (Ranks), and Google Play (Ranks).