Historical reports from Google currently unavailable
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Oct 17, 2022 - 14:19 EDT
Update
We've completed the re-imported process for Google's reports. If you're still seeing anything that looks incomplete reach out to support for a closer look.
Posted Oct 17, 2022 - 14:18 EDT
Monitoring
Google has regenerated downloadable reports, which were previously removed for months prior to August 2022. Now that these are available again, we'll be able to re-import historical reports for all impacts accounts.

As soon as the re-import process has been completed within Appfigures, over the next few days, we'll share that update here.
Posted Oct 11, 2022 - 17:44 EDT
Update
Google is still working to regenerate historical reports. We'll import reports for all impacted as soon as those are available once again.
Posted Oct 05, 2022 - 10:32 EDT
Update
Google is still working to fix their missing downloadable reports prior to August 2022. Once those become available again we'll be able to sync for impacted accounts.
Posted Sep 27, 2022 - 16:20 EDT
Identified
Google has recently announced that downloadable monthly reports, of which we import for reporting, are currently unavailable prior to August 2022. Developer accounts being linked for the first time, or accounts that have not synced in related months, will be impacted.

Once Google resolves their ongoing issue, we'll be able to import any historical monthly reports that have not been available from the above.
Posted Sep 21, 2022 - 12:10 EDT
This incident affected: Google Play (Downloads).