ASO Data Delays

Incident Report for Appfigures

Resolved

Everything has returned to normal and ASO updates are fully caught up.
Posted Mar 04, 2026 - 16:48 EST

Monitoring

Things are looking much better, and ASO updates are catching up. Everything appears back to normal, but we’ll keep monitoring for a bit to make sure it stays that way.
Posted Mar 04, 2026 - 14:43 EST

Identified

We’re investigating some ASO-related hiccups. During this time, you may experience intermittent timeouts and delayed data refreshes.
Posted Mar 04, 2026 - 11:08 EST
This incident affected: ASO.