Google data delayed after August 8th
Incident Report for Appfigures
Resolved
Google is up to date with data for the 14th. Now that they're back on track for their usual report release times we'll happily close this one!
Posted Aug 17, 2023 - 16:39 EDT
Update
Google has released data for the 13th so we're getting closer to Google's standard release schedule!
Posted Aug 17, 2023 - 10:29 EDT
Update
Important: while Google has started releasing reports with data from the 9th and on, not all developers are seeing the updated dates in their downloadable reports. We've noticed that Google has recently been releasing reports in batches, at different times, which is likely the case here. We'll continue to monitor until all developers have data for those days.
Posted Aug 16, 2023 - 10:47 EDT
Update
Google has started releasing data between the 9th through the 12th. We will automatically import those dates for everyone.

Data for the 13th and on has not yet been released so we'll continue to monitor for a bit longer.
Posted Aug 16, 2023 - 10:27 EDT
Monitoring
Google has not released data, for free apps, after August 8th. So the latest date available is currently the 8th. On average, Google does release reports two to three days after the expected date however, in this case it's longer than usual.

Once reports are released with data for the 9th and on, we'll automatically import for everyone.
Posted Aug 15, 2023 - 09:38 EDT
This incident affected: Google Play (Downloads).