Looking Into November Google Revenue Increase

Incident Report for Appfigures

Update

A fix for the Google subscription delays and duplication is rolling out now. Next, we’ll re-import November and December to correct any data issues from the last few days. We’ll be monitoring the re-import over the next few hours.
Posted Dec 04, 2025 - 18:15 EST

Update

We’re pushing out another update to deal with Google’s recent changes to their monthly reports for November and December. We’ll re-import both months for all accounts and keep an eye on things from here.

Subscription delays are still being looked into as part of the same report changes. We’ll share more as soon as we know more.
Posted Dec 04, 2025 - 12:53 EST

Update

We’ve re-imported November reports for everyone. After the re-import, we’re still seeing some lingering discrepancies and delays in subscription data due to Google’s report changes, and we’re continuing to investigate.

We’ll share another update on Google’s November and December numbers as soon as we have more to report.
Posted Dec 03, 2025 - 20:40 EST

Monitoring

The fix for inflated Google paid revenue is live. We’re currently cleaning up November reports and will share a final update when that’s complete.
Posted Dec 03, 2025 - 10:55 EST

Update

We’ve located the root cause — additional changes in Google’s updated reports starting in December. We’re working on a fix to handle these changes and will reimport November and December reports as soon as it’s ready.
Posted Dec 02, 2025 - 16:51 EST

Identified

We’ve zeroed in on where the issue lives and are tracking it down. A fix is on the way.
Posted Dec 02, 2025 - 15:31 EST

Update

We’re still digging into the root cause of the revenue spike and hope to share more soon.
Posted Dec 02, 2025 - 11:50 EST

Update

Quick update: We’re still digging into the November Google revenue spike. We’ll share more once we know more.
Posted Dec 02, 2025 - 10:37 EST

Investigating

We’re currently looking into a jump in Google revenue for November after receiving reports that the numbers may be inflated. We’ll share more updates as we learn more.
Posted Dec 02, 2025 - 09:37 EST
This incident affects: Google Play (Revenue).