AdMob syncs are running normally again, and everyone should now have up-to-date data. Syncs will continue running successfully going forward, and no action is needed on your end.
If you're still seeing anything that looks delayed, reach out to the support team for a closer look.
Posted May 28, 2026 - 20:04 EDT
Monitoring
AdMob syncs are running again, and data is importing normally.
We’ll resolve this incident once the remaining syncs finish catching up.
Posted May 28, 2026 - 14:08 EDT
Identified
We’re currently rolling out a fix to get AdMob syncs back up and running.
We’ll share another update as soon as it’s fully live.
Posted May 28, 2026 - 13:56 EDT
Investigating
We’re still investigating issues with AdMob syncs.
If you run a manual sync, you might see a message saying your credentials need to be updated - even if they haven’t changed. That’s part of the issue we’re looking into, so there’s nothing you need to do on your side right now.
We'll hopefully have more info to share today.
Posted May 28, 2026 - 10:29 EDT
Identified
We’re still investigating sync issues affecting most AdMob accounts. We’ll keep you posted as soon as we have more to share.
Posted May 27, 2026 - 14:14 EDT
Investigating
We're currently investigating sync issues affecting most AdMob accounts. We're actively working to identify the root cause, and we'll share updates here as soon as we have more information.