App Store Connect delays for 4/1
Incident Report for Appfigures
Resolved
Apple has (finally) released new report for Thursday, 4/1.

Reports have been imported automatically and email reports have gone out.
Posted Apr 02, 2021 - 21:44 EDT
Identified
Apple's raw sales and subscription reports for 4/1 are currently delayed however, data is reporting in the Sales and Trends dashboard of App Store Connect.

Once the raw reports from Apple are released for yesterday, we'll automatically begin importing data.
Posted Apr 02, 2021 - 14:56 EDT