App Store Connect Sync Issues

Incident Report for Appfigures

Resolved

We've been closely monitoring Apple syncs since deploying the fix, and everything is now operating as expected.

If you're still experiencing any lingering issues, reach out to our support team and we'll be happy to take a closer look.
Posted Jun 05, 2026 - 16:51 EDT

Monitoring

The update has been deployed and we're now syncing data and monitoring results.

If you were impacted by this issue, you should begin seeing data update as syncs complete. We'll continue to monitor and share a final update once we've confirmed everything is operating normally.
Posted Jun 04, 2026 - 17:32 EDT

Identified

We've identified the root cause of the App Store Connect sync issues and are rolling out a fix for affected accounts now.

Once the fix is live, we'll trigger a sync for those accounts. We'll share another update once that's running.
Posted Jun 04, 2026 - 17:05 EDT

Update

We're still actively investigating the App Store Connect sync issues affecting a handful of accounts. For affected accounts, you may see an "invalid credentials" message during sync attempts.

We'll post another update as soon as we have more information.
Posted Jun 04, 2026 - 12:40 EDT

Investigating

We're currently investigating App Store Connect sync issues affecting a small number of accounts.

We're still working to understand what's causing the issue, but we're actively investigating. We'll share more details here as soon as we know more.
Posted Jun 04, 2026 - 10:36 EDT
This incident affected: Apple (Downloads & Revenue, Subscriptions).