Investigating Google Revenue for Paid Apps

Incident Report for Appfigures

Resolved

Google Play paid apps have continued to import data without issue over the last few days.
Posted Mar 11, 2025 - 12:13 EDT

Monitoring

We've rolled out a fix based on Google's change, and we're importing revenue for paid apps again. Data is catching up as we re-import for all impacted accounts. We'll monitor until syncs are complete.
Posted Mar 06, 2025 - 13:18 EST

Update

We have an update in the works to bring back revenue for paid apps. We'll run some additional tests and have the changes out once that's completed.
Posted Mar 05, 2025 - 17:03 EST

Update

We determined the root cause of the paid app revenue drop for February and on - a change from Google. We're searching for a workaround and want to have this in place as soon as possible.
Posted Mar 05, 2025 - 09:56 EST

Update

We'll continue to work on this until the root cause has been determined and revenue is importing once again.
Posted Mar 04, 2025 - 20:01 EST

Update

We're continuing to investigate the root cause and will share any new updates as they become available.
Posted Mar 04, 2025 - 16:34 EST

Identified

We've identified the issue of the missing revenue for paid apps and are now looking to understand the root cause.
Posted Mar 04, 2025 - 10:47 EST

Investigating

From February on, we're investigating reports of dropped Google revenue for paid apps. This only impacts paid apps; IAP revenue continues to be available in reporting.
Posted Mar 04, 2025 - 10:12 EST
This incident affected: Google Play (Revenue).