Sales report delays for free Google apps after October 19th
Incident Report for Appfigures
Resolved
Google has now released data up to October 28th. With the 28th available, it's in line with Google usual report release schedule for free apps - which is about three days.
Posted Nov 01, 2024 - 11:15 EDT
Update
The latest report available in the monthly report for October is the 27th. Google continues to be more delayed than normal this month. We'll continue to keep an eye on it!
Posted Oct 31, 2024 - 12:57 EDT
Update
Google has released additional days up to and including October 25th. We'll import all days, automatically.
Posted Oct 29, 2024 - 08:02 EDT
Update
We're still waiting on Google to release reports with data after October 19th. We'll automatically import for everyone when additional days are made available.
Posted Oct 28, 2024 - 10:57 EDT
Monitoring
Google is behind schedule with releasing sales data, for free apps, as the latest date available in downloadable reports is October 19th. Downloads are not available for any dates after the 19th. We'll import for everyone as soon as any additional days are released.

Note: Data is available in the developer dashboard already however, we import based on the downloadable reports.
Posted Oct 25, 2024 - 14:24 EDT
This incident affected: Google Play (Downloads).