Issues loading ASO reports
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Apr 12, 2020 - 19:20 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2020 - 17:58 EDT
Investigating
We're investigating reports of ASO reports not loading for some members
Posted Apr 12, 2020 - 17:02 EDT
This incident affected: ASO.