Google Play Delay for Free Apps
Incident Report for Appfigures
Resolved
We have great news to share - We found a workaround that eliminates the new delay from Google Play and it's live!

With Google's extended delay, report release times going from 2 days to five days, we found a workaround that would bring data in more quickly, which enables having only a single-day delay.

The workaround enables us to access daily information directly from Google that isn’t in the downloadable reports as a new data source. We’ll use the new data source for all days delayed by Google until they are available in the original data source. This is how you’ll now be able to see data for yesterday on the platform.
Posted Jan 30, 2025 - 14:12 EST
Update
Google's reports are once again being released with the standard 3-5 day delay schedule. The latest report available is January 16th, released earlier today, January 20th.
Posted Jan 20, 2025 - 20:04 EST
Update
January 13th is the latest date with available data from Google.
Posted Jan 17, 2025 - 18:45 EST
Update
Good news! Google has released additional days up through and including January 11th. We're in the process of syncing all accounts for up-to-date data.

We'll monitor for a few more days in hopes that Google's release schedule returns to normal and data is released daily.
Posted Jan 15, 2025 - 13:59 EST
Update
We're still waiting for Google to release reports with data after January 1st. Hopefully soon they'll release updated reports with additional days.
Posted Jan 13, 2025 - 12:20 EST
Update
Google has still not updated reports, for free apps, after January 1st. We've reached out to Google about the ongoing delay.

We'll import additional days as soon as those become available.
Posted Jan 10, 2025 - 12:46 EST
Monitoring
Google Play data, for free apps, is delayed as the latest date available in Google's reports is January 1st. We've reached out to Google about the growing delay for this month.

In the past, Google's usual report release schedule was, on average, about three days. The new normal from Google is about five days, minimum. This current delay, which is over a week, is unusual but not unheard of.

Reports for paid apps/products continues to be released at the expected day/time where data is available through January 8th.

As additional days of data become available we will automatically import for everyone.
Posted Jan 09, 2025 - 12:59 EST
This incident affected: Google Play (Downloads).