Google's delay with free app data after 7/3
Incident Report for Appfigures
Resolved
Google has recently released reports up to and including the 7th of July. Automatic syncs will pick up on any available data during those days.

We're resolving this one now as we're currently working with Google's typical delay of releasing reports a day or two behind. We'll continue to import days as the 8th and onward are made available.
Posted 6 days ago. Jul 09, 2019 - 18:32 EDT
Monitoring
Google Play is delayed with releasing reports, covering free apps, after the 3rd of July. While the dashboard may have more up to date data, the raw reports which we use have not yet been generated. We'll import those last few days as soon as they become available.
Posted 8 days ago. Jul 08, 2019 - 10:47 EDT
This incident affected: Google Play (Downloads).