Errors in ASO Reports

Incident Report for Appfigures

Resolved

Errors have subsided, and all ASO reports are back up and running as usual.
Posted Jun 11, 2025 - 02:01 EDT

Investigating

We're investigating errors in ASO reports, including Inspector, Keyword Performance, and Related Keywords.
Posted Jun 11, 2025 - 01:54 EDT
This incident affected: ASO.